[Linux-bruxelles] problème de serveur web avec un modem SpeedTouch 510 (ip dynamique, DNS chez dyndns.org)

Frederic Pasteleurs masterfrd at tiscalinet.be
Jeu 5 Fév 18:30:51 CET 2004


Rusinsky Stanislas Herman W. A. wrote:
> 
> suite à la promo (36€ le SpeedTouch 510, cf. la longue discussion sur
> cette liste il y a peu) je me suis acheté le modem, et j'essaye de faire
> tourner un site de chez moi.
> 
> Je n'arrive pas à configurer le modem pour qu'il fasse du full NAT vers 
> mon serveur (10.0.0.40) qui se trouve derrière.
> 
> PC1 10.0.0.40 \
>                >---  10.0.0.138<- SpeedTouch510 -> 81.240.20.**
> PC2 10.0.0.41 /
> 
> Quelqu'un l'aurais déjà fait? J'ai essayé les options du NAPT de toute
> les manières qui me semblaient logiques... mais rien...
> 
> Quand le modem est configuré de manière standard, ç-à-d sans NAPT, je
> peux accéder au menu du modem via l'adresse IP externe, dès que le NAPT
> est mis d'une quelconque manière vers PC1 10.0.0.40 (menu: via le NAPT
> entries || via le Multi-Nat entries || Default Server) ça ne marche pas.
> Dès que le NAPT est mis, j'ai un 'operation timed out when attempting to
> contact ***.dyndns.org',

L'idéal serait de poster ton fichier user.ini dépouillé des mots de 
passe. :-)

Pour un serveur web, tu dois avoir dans la section [ nat.ini ] la ligne 
suivante:
create protocol=tcp inside_addr=10.0.0.40:www-http 
outside_addr=0.0.0.0:www-http

Tu peux récupérer/placer ce fichier via ftp sur ton routeur.

> en local (http://10.0.0.40/) je sais accéder à mon serveur web, je peux
> aussi pinger l'adresse extérieure depuis PC2 et là il me met:
> 
> ping ***.dyndns.org
> PING ***.dyndns.org (81.240.20.**) 56(84) bytes of data.
> 64 bytes from 10.0.0.40: icmp_seq=1 ttl=64 time=0.816 ms
> 64 bytes from 10.0.0.40: icmp_seq=2 ttl=64 time=0.809 ms
> 64 bytes from 10.0.0.40: icmp_seq=3 ttl=64 time=0.813 ms
> 64 bytes from 10.0.0.40: icmp_seq=4 ttl=64 time=0.812 ms
> 64 bytes from 10.0.0.40: icmp_seq=5 ttl=64 time=0.809 ms
> 64 bytes from 10.0.0.40: icmp_seq=6 ttl=64 time=0.808 ms
> 

Il faut voir quelle version du firmware tu utilise, les anciennes 
versions ne permettaient pas de joindre l'adresse WAN depuis le LAN

Via telnet, au prompt "=>", taper la commande software version (l'avant 
dernière version, à ma connaissance, porte la version .741) si ta 
version est inférieure à ce nombre, tu peux envisager de le reflasher.

> J'avoue un peu me mêler les pinceaux et espérer l'avènement de l'IPv6
> pour bientôt.

Ces firmwares ne supportent pas l'IPv6, désolé. :-(


-- 
Frederic Pasteleurs [http://belzebuth.ath.cx]
Jabber:askarel at amessage.be

O____ Fingerprint: 706B F52B 8629 A105 2E87  AC07 C154 5BC3 3158 53F9
O  || http://pgp.ael.be:11371/pks/lookup?op=get&search=0x315853F9


-------------- section suivante --------------
Une pièce jointe autre que texte a été nettoyée...
Nom: non disponible
Type: application/pgp-signature
Taille: 189 octets
Desc: non disponible
URL: <http://listes.domainepublic.net/pipermail/linux-bruxelles/attachments/20040205/31183dfe/attachment.sig>


Plus d'informations sur la liste de diffusion Linux-bruxelles